Subject: fxp issues
To: NetBSD/i386 mailing list <>
From: Sean Davis <>
List: port-i386
Date: 07/20/2004 09:35:59
Hello, I have a machine here running 2.0G (the snapshot from the 17th,
from releng, with a custom kernel), and I'm having some problems with
the fxp driver.

Every <regular interval> (not sure what the interval is, but it is
regular), my fxp NIC drops right off the network, then comes back a
few seconds later, without any errors or printing anything to dmesg,
even with debug turned on in ifconfig. It's an onboard card, so I
can't just swap it out (nor can I disable it, unless there is a BIOS
option I missed...)

Has anybody had this particular issue before?
Here is the relevant dmesg information:

fxp0 at pci0 dev 9 function 0: i82558 Ethernet, rev 5
fxp0: interrupting at irq 10
fxp0: Enabling receiver lock-up workaround
fxp0: Ethernet address 00:50:ba:00:00:33
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 0
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

I tried adding the 'link0' option, which caused the following to
appear in dmesg:
fxp0: Microcode loaded: int delay: 1000 usec, max bundle: 0
But I don't think that has anything to do with the real problem.

It is worth noting that this machine came with FreeBSD on it - and I
never noticed this happening under FreeBSD. I switched to NetBSD
because it's easier for me to maintain (I run NetBSD on all my
machines), but this behavior is troubling. Any ideas? This machine is
useless if I can't keep it on the network, and right now I don't have
the cash to buy even a cheap realtek card. It doesn't seem to happen
in 10baseT full-duplex mode, only in 100baseTX full-duplex mode.

Any help is appreciated. I can forward along the kernel config if desired.