Subject: Re: Intel 82865G graphics
To: Mark Davies <>
From: Steven M. Bellovin <>
List: port-i386
Date: 07/19/2004 23:13:25
In message <>, Mark Davies writes:
>On Tue, 20 Jul 2004 03:34, Steven M. Bellovin wrote:
>> >Has anyone successfully used X windows on one of these? Any caveats?
>> I'm currently having a lot of trouble -- it works for me with XFree86
>> 4.3, but not with 4.4.  See xsrc/26106.  I've gotten no help from the
>> XFree86 community, and I've been unable to localize the problem at all.
>> I do not recommend that chip -- if my system had an AGP slot, I'd buy a
>> new card.
>We have a bunch of Dell GX270's with these in them:
>agp0 at pchb0: detected 8060k stolen memory
>agp0: aperture at 0xe8000000, size 0x8000000
>vga1 at pci0 dev 2 function 0: Intel 82865G Integrated Graphics Device (rev. 

I have the same lines.
>And we are running them with 4.4 and 1280x1024 32bpp.
>We originally had X complaining that it couldn't find a useable video mode.  
>This was because the BIOS thought it only had 1M available to the graphics 
>chip.  To get around that we had to change the BIOS setting for the "Onboard 
>Video Buffer" to 8MB *AND* we had to downgrade the BIOS version from A03 to 
>A02 so that it would actually have an effect (seems the A03 BIOS had a bug).

There's no such BIOS option on my machine (an HP dc5000).  I tried 
upgrading the BIOS; it made matters worse (though I haven't tried 4.3.0 
with the newer BIOS).
>There is supposed to be code in the XFree  i810 driver to get around this 
>issue of the BIOS only reporting 1M as it seems its quite common but it 
>didn't work of the Dell's.
>Intersting bits of the XFree86.0.log would be:

My log file is just about the same.  The problem in my case is a bit 
later -- 

>(II) I810(0): Integrated Graphics Chipset: Intel(R) 865G
>(--) I810(0): Chipset: "865G"
>(--) I810(0): Linear framebuffer at 0xE8000000
>(--) I810(0): IO registers at addr 0xFEB80000
>(WW) I810(0): remove MTRR feb80000 - fec00000
>(II) I810(0): detected 8060 kB stolen memory.
>(II) I810(0): I830CheckAvailableMemory: 964608 kB available
>(II) I810(0): Will attempt to tell the BIOS that there is 8128 kB VideoRAM
>(WW) I810(0): Extended BIOS function 0x5f11 not supported.
>	[...]
>(II) I810(0): VESA BIOS detected
>(II) I810(0): VESA VBE Version 3.0
>(II) I810(0): VESA VBE Total Mem: 8000 kB
>(II) I810(0): VESA VBE OEM: Intel(r)865G Graphics Chip Accelerated VGA BIOS
>(II) I810(0): VESA VBE OEM Software Rev: 1.0
>(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
>(II) I810(0): VESA VBE OEM Product: Intel(r)865G Graphics Controller
>(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
>(II) I810(0): BIOS view of memory size can't be changed (this is not an 
>(--) I810(0): Pre-allocated VideoRAM: 8060 kByte
>(==) I810(0): VideoRAM: 8192 kByte
>(==) I810(0): video overlay key set to 0x101fe
>(--) I810(0): Maximum frambuffer space: 8040 kByte
My log file is just about the same.  The problem in my case is a bit 
later -- I get this:

(II) Module ddc: vendor="The XFree86 Project"
	compiled for 4.4.0, module version = 1.0.0
	ABI class: XFree86 Video Driver, version 0.7
(II) I810(0): VESA VBE DDC supported
(II) I810(0): VESA VBE DDC Level none
(II) I810(0): VESA VBE DDC transfer in appr. 0 sec.
(II) I810(0): VESA VBE DDC read failed

That causes it not to get valid video modes.  (To be sure, there's some 
enumerated dump just after that that shows lots of modes, but not in 
the place X wants them.  It's the enumerated dump that didn't work with 
the newer BIOS.)

If anyone has any suggestions, my log files are at

		--Steve Bellovin,