Subject: ICH5/82801EB IDE Controller P-ATA?
To: NetBSD/i386 List <port-i386@NetBSD.ORG>
From: Paul Ripke <>
List: port-i386
Date: 07/12/2004 18:19:40
I've picked up a new box with an ASUS P4P800-E Deluxe motherboard. I
did some checking to make sure enough of it was supported before
buying. I figured the HT support might be questionable, and the
onboard RAID out of the question. However, I find that I can't get
to my P-ATA drives (ST340014A, ST3120026A and a 48x CD-ROM).

I've tried a few different combos, I was hoping someone might point
me in the right direction.

1.6.1 iso:
  - didn't expect this to work much at all.
  - finds all attached drives via pciide, but hangs right at the end
    of the kernel messages, after printing:
    "biomask ffed netmask ffed ttymask ffef"
1.6.2 iso:
  - didn't expect this to be much different to 1.6.1.
  - configures the controller via pciide but no disks.
  - doesn't hang.
2.0 beta iso with INSTALL kernel:
  - configures the controller via piixide, but still no disks.
  - if I enable USB and 1394 in the BIOS, I get the following
    message when piixide is configuring the second channel:
    "intr_establish: pic pic0 pin 15: can't share type 3 with 2"
    similar error further along for the AGP card.
2.0 beta custom kernel with acpi+ioapic+mpacpi
  - piixide attaches, but still no disks.
  - HT works! :)
  - also tried ACPI_PCI_FIXUP - no change.

Googling around, I see people running similar beasts. Any
hints? I'm planning on running 2.0 on this medium term.

I'm currently building a custom kernel from HEAD to see if
anything changes. I might also stick a spare NIC in it, so at
least I'll be able to ftp off the dmesg.

FYI: There also appears to be some issue with sk/skc talking
to a Marvell Yukon chipset. I'll investigate this after I get
the disks working. I did install XP, and everything seems about
as OK as I'd expect for XP (drives and NIC worked).