Subject: Re: 2.0G breaks thinkpad
To: Simon J. Gerraty <>
From: Steven M. Bellovin <>
List: port-i386
Date: 07/05/2004 15:12:34
In message <>, "Simon J. Gerraty" write
>On Sat, 03 Jul 2004 14:21:08 -0400, "Steven M. Bellovin" writes:
>>>I have a 2.0G install CD I burned that I can try on that machine in a 
>>>little while.
>>I just tried the install CD, built from yesterday's -current source.  
>>On a Thinkpad R51, wm0 worked perfectly -- it acquired an address via 
>>dhclient, and was able to ping things.
>Odd.  I re-built my 2.0G kernel from clean tree (updated Jul  2 15:25)
>and simply could not get anything out of wm0, even with manual config.
>My rc.conf does a 'ifconfig wm0 up' which seems to help 2.0E get the
>thing going, when I rebooted again with the 2.0E kernel dhclient got
>a lease on first try.
>Which kernel were you using - my custom kernel contains various tweaks
>from perry, but I had no luck with the 2.0G GENERIC_LAPTOP kernel either.

The kernel is pretty standard -- I started with GENERIC_LAPTOP and 
added a few things like IPSEC, but that's about it.

		--Steve Bellovin,