Subject: Re: 2.0G breaks thinkpad
To: Tom Ivar Helbekkmo <>
From: Steven M. Bellovin <>
List: port-i386
Date: 07/03/2004 14:21:08
In message <>, "Steven M. B
ellovin" writes:
>In message <>, Tom Ivar Helbekkmo writes:
>>"Simon J. Gerraty" <> writes:
>>> I just loaded my laptop from a tree updated and built today.
>>> and wm0 no longer works -  device times out.
>>Are you sure that's new?  I've long had trouble with wm0 on my
>>Thinkpad X31, but have fixed it by having scripts (run by apmd and
>>ifwatch) that explicitly ifconfig it down at suspend and when it loses
>>carrier, and up at resume and when it regains carrier.
>My daughter has new Thinkpad R51 that's had no such problems, under 
>2.0beta.  I did write an apmd/resume script to restart dhclient, under 
>the assumption that if you've moved you may need new addresses, but not 
>due to any carrier detect bugs.
>I have a 2.0G install CD I burned that I can try on that machine in a 
>little while.

I just tried the install CD, built from yesterday's -current source.  
On a Thinkpad R51, wm0 worked perfectly -- it acquired an address via 
dhclient, and was able to ping things.

		--Steve Bellovin,