Subject: suspend/resume problem with IBM T30 with mixer open
To: None <>
From: Greg Troxel <>
List: port-i386
Date: 03/16/2004 20:27:05
I have an IBM Thinkpad T30 running -current from about a month ago.  I
installed gnome 2.4 with native pthreads, and pretty much everything
is ok.  I have been suspend/resuming this machine for 15 months with
little trouble, mostly under 1.6.x - just the usual
switch-to-text-console-to-avoid-borked-videomodes-on-resume problem
with the 1400x1050 displays.  On -current, suspend/resume worked fine
(with the workaround).

I then built/installed gnome2.  My normal practice is to switch to
ttyE0, run a script that ifconfig's interfaces down, and suspend.  On
resuming, I run a script that ifconfig/dhclient/whatever for the new
location, and then I switch back to ttyE4 where gnome/X is running.  I
found that on resuming the machine was locked up hard and totally
unresponsive.  I suspected sound, and removed the volume control
applet from the panel (which had /dev/mixer0 open), and then a
suspend/resume was normal.

So, my working hypothesis is that the mixer device being open across a
s/r doesn't work on this box.  Has anyone else seen similar issues?

auich0 at pci0 dev 31 function 5: i82801CA (ICH3) AC-97 Audio
auich0: interrupting at irq 11
auich0: ac97: Analog Devices AD1881A codec; headphone, Analog Devices Phat Stereo
auich0: ac97: ext id 1<VRA>

Sound playback works fine; I haven't played with input much.

        Greg Troxel <>