Subject: Re: NetBSD on IBM PS/2 9595
To: Jaromir Dolecek <>
From: Carl Drougge <>
List: port-i386
Date: 11/29/2001 03:15:52
On Wed, Nov 28, 2001 at 09:52:39PM +0100, Jaromir Dolecek wrote:

> > Booting proved troublesome, saying just "Boot failed". Setting the floppy to
> > 1.44MB mode solved this (and of course caused errors in POST..), which makes
> > me think the bootloader tried to read the floppy as 2.88MB. (DOS boots fine
> > from floppy, and IIRC so does linux (using whatever Debian 2.0 used on their
> > boot-floppy).)
> Well, the image is done for 1.44MB floppy. Perhaps the geometry or
> something was not right when copied to floppy in 2.88MB mode? Having
> not used 2.88MB floppy before, I'm not particularily aware of
> possible problems/incompatibilities. Perhaps someone else can comment?

I wrote it as 1.44MB (my desktop system has a normal floppy..). If I had
written it on the PS/2 it might have worked, but I figured it was easier to
write it on a computer that was already running.. =)

(The point is that DOS written to the same disk using the same desktop
computer will boot just fine, so there *is* a bug in the NetBSD bootloader.)

> > > ep0 at mca0 slot 4 irq 10: 3Com 3c529-TP Ethernet Adapter
> > > ep0: address 00:20:af:18:48:d4, 8KB byte-wide FIFO, 3:1 Rx:Tx split
> > > ep0: 10baseT, 10base5 (default 10base5)
> > 
> > I was unable to receive packets on this interface (sending worked though).
> > (Using the AUI-port, since I don't have a convinient place to put the other
> > end of a TP-cable.)
> This is strange. I'm using ep on my box as a primary network
> controller for NFS root, it's working very well for me. In 10baseT
> mode, tho.  What does ifconfig -a say after boot? Note the 'default
> 10baseX' message might be bogus, the value used is the one setup
> in the configuration utility of Reference Disk.

The message is bogus, and ifconfig says 10baseT, but I changed it..
("ifconfig ep0 media aui") But maybe that doesn't work, and it always
transmits on both ports, or something..

I tried again, after changing it in setup. It still says 10base5 during
boot, but now also says so in ifconfig. And, it also works. I think changing
media-type is broken for ep.. Now if only I wasn't so lazy I'd have a go
with NFS root..

> Model 95 is the one with LED display, right? I'd eventually like
> to write some support code for this, and would need testers then
> (I don't have model 9X PS/2 available) :)

It is. Too bad it's only 8x1 chars.. (And, in case you haven't looked at it,
extremely easy to control. 8 consecutive io-ports, one for each char, from
right to left, starting, I think, at 0x110.)