Subject: Re: Naive question re: source
To: Steven M. Bellovin <>
From: Steven Sartorius <>
List: port-i386
Date: 11/03/2001 13:09:37
on 11/3/01 8:12, Steven M. Bellovin at wrote:

> In message <20011103114524.A29567@localhost>, Bernd Sieker writes:
>> On 02.11.01, 11:24:30, Todd Vierling wrote:
>>> On Fri, 2 Nov 2001, Steven Sartorius wrote:
>>> : I have a (possibly) naive question about building world from source.
>>> : Yesterday I supped allsrc from the release-1-5 collection.  I built a kern
>> el
>>> : with no problems (id's itself as 1.5.3_ALPHA) and then tried a 'make build
>> '.
>>> : This died with the horrific message below:
>>> : > -DFLOATING_POINT -c /usr/src/lib/libc/gen/__glob13.c
>>> : > cc: Internal compiler error: program cc1 got fatal signal 11
>>> : Is the above indicative of a bootstrapping problem or something more
>>> : severe?
>>> This looks like you may have bad memory, or bad factors relating to memory
>>> (such as overclocking, setting the memory latency values in the BIOS too
>>> low, or using a motherboard that isn't as reliable as claimed when running
>>> at the highest supported FSB speed).
>>> There are standalone (run-from-DOS) memory testing programs out there as
>>> freeware; one such program is in pkgsrc/sysutils/memtest (it creates a
>>> dd'able 1.44M bootable floppy image).
>> Try running "make build" repeatedly after such a failure. The most
>> tell-tale sign of faulty hardware (as opposed to broken sources) is
>> that it bails out at different places each time.
>> There is even a large FAQ page about the most frequent and/or most
>> likely causes of the infamous "fatal signal 11" error from gcc.
> Indeed.  I reported similar symptoms, and got similar advice; pulling
> one SIMM solved my problems immediately.
> --Steve Bellovin,
> Full text of "Firewalls" book now at
I'm sure this is probably it -- I added 2 256MB SIMMs to the machine a
couple of weeks ago.  Guess I didn't stress it enough until yesterday.