Subject: Lucent Wavelan on new Compaq M300
To: None <>
From: Ed Gould <>
List: port-i386
Date: 11/09/2000 11:38:02
I just upgraded my Compaq M300 to a newer version of the same machine.  The 
old one had a Celeron CPU and an 800x600 screen; the new one is a P-III, 
1024x768.  The new one also has cardbus, where the old one may not have (I ran 
it fine without cardbus support in my kernel).

My Lucent WaveLan card worked fine on the old machine, but not on the new one. 
 Here are excerpts from the boot messages (a slightly older kernel, without 
cardbus compiled in, didn't even find the card):

   NetBSD 1.5J (ROME) #75: Thu Nov  9 10:05:19 PST 2000
   cpu0: Intel Pentium III (E) (686-class), 597.79 MHz
   cpu0: I-cache 16K 32b/line 4-way, D-cache 16K 32b/line 2/4-way
   cpu0: L2 cache 256K 32b/line 8-way
   cpu0: features 383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR>
   cpu0: features 383f9ff<PGE,MCA,CMOV,FGPAT,PSE36,MMX,FXSR,XMM>
   total memory = 65084 KB
   avail memory = 55520 KB
   using 839 buffers containing 3356 KB of memory
   BIOS32 rev. 0 found at 0xf0000
   cbb0 at pci0 dev 4 function 0: Texas Instruments PCI1211 PCI-CardBus Bridge 
(rev. 0x00)
   cbb0: interrupting at irq 11
   cbb0: cacheline 0x8 lattimer 0x20
   cbb0: bhlc 0x24208 lscp 0x20010100
   cardslot0 at cbb0 slot 0 flags 0
   cardbus0 at cardslot0: bus 1 device 0 cacheline 0x8, lattimer 0x20
   pcmcia0 at cardslot0
   pcmcia0: CIS version PC Card Standard 5.0
   pcmcia0: CIS info: Lucent Technonogoes, WavevAN/IEEE, Versiono01.01, 
   pcmcia0: Manufacturer code 0x156, product 0x2
   pcmcia0: function 0: network adapter, ccr addr 3e0 mask 1
   pcmcia0: function 0, config table entry 1: I/O card; irq mask ff46; iomask 
6, iospace 0-3f; io16 irqpulse irqlevel
   wi0 at pcmcia0 function 0: Lucent Technonogoes, WavevAN/IEEE, 
   wi0: init failed
   wi0: could not get mac address, attach failed

Any thoughts?  Should I PR this?  (Of course, it all works under Windoze, so 
it's not a hardware failure.)