Subject: gethostbyname and linux emul?
To: None <>
From: Jon Lindgren <>
List: port-i386
Date: 09/26/2000 09:15:09
I'm trying to run TIBCO's Rendezvous product under NetBSD-1.5_ALPHA2 on a
p90 machine.  NetBSD is wonderful, however, running their daemon fails -
it complains that gethostbyname() failed.

I've installed suse_base, suse_compat and suse_libc.  The product _does_
startup, so I'm assuming linux emul is at least working.  Maybe setup
incorrectly, but installed okay.

Pinging my own host name works.  'hostname' returns the proper 
stuff.  /etc/hosts is groovy.  /etc/resolv.conf is set correctly.  I even
tried removing dns from /etc/nsswitch.conf to remove improper dns
setup from the equation.  No go.  Big frowns.

After a fitful night of no inspiration, I tried copying /etc/hosts to
/emul/linux/etc - still no go.  Still no other inspiring ideas.

Is there something I've overlooked, perhaps a trick, or am I out of
luck?  Can someone point me in the right direction?

 "Trout are freshwater fish, and have underwater weapons."
 "Zing, zing zing zing!"
 "Keep away from the trout."
 -- The opinions expressed are not necesarily those of my employer --
 "Who stole my lawn?"