Subject: Re: largepage success
To: None <>
From: Brian Gregor <>
List: port-i386
Date: 09/08/2000 15:49:14
I've tried compiling & running a LARGEPAGES kernel on my PC.  Hardware:
K6-III 350 MHz, 128 meg RAM, compiling on a Seagate SCSI-2 disk on a
DPT Smartcache III PCI controller.

Here's what I have for results:
	compile GENERIC:   user       system        real
4MB patch                10m35.710s  0m38.686s    14m17.171s
normal                   10m26.632s  0m34.549s    14m15.473s
No difference!  Is the LARGEPAGES patch intel specific?  To generate
my kernel, I just copied DR-EVIL.4MB and changed it to load my kernel
config.  I also tried lmbench to see if there was any improvement, and
there was no apparent difference between the largepages & standard 
kernels.  Each compile of GENEREIC above was done after a reboot.


On Fri, 8 Sep 2000, Manuel Bouyer wrote:

> Hi,
> FYI, I'm running with the LARGEPAGES kernel option on my amd K6/II, without
> apparent problem. I didn't run benchmarks as the machine isn't idle, though.
> --
> Manuel Bouyer, LIP6, Universite Paris VI. 
> --