Subject: Re: xanim-2.81
To: None <,>
From: None <>
List: port-i386
Date: 10/25/1999 09:15:27
On Sun, Oct 24, 1999 at 02:22:58PM +0000, Mario Kemper wrote:
> 	Hi,
> i tried to play around with the new xanim-2.81, as our packaged one lacks 
> almost all codes you need today. It uses loadable dll's for the newer codecs. 
> Podlipec still doesn't seem to have access to a netbsd machine so there are no
> libs for NetBSD. So i played with the linux version. I grabbed the xanim.rpm 
> from  a SUSE server and some libs from xanims homepage. 
> But when xanim tries to load a codec i get unresolved errors and dlopen fails.
> I use the package suse_linux.
> Did anybody have more success with xanim?

I had to change the configuration to build with loadable module
support.  I then tried to use the freebsd dynamic elf libs, which
worked (well, it loaded, I didn't have a movie which needed them
just yet) , but only for one lib in the directory at a time.  This
is actually a bug in our dlsym() implementation that at least 2
PR's have been filed against.  We search every loaded object
instead of the object specified in the dlsym() call.