Subject: Re: Something wrong with disklabel....
To: orione <>
From: Thilo Manske <Thilo.Manske@HEH.Uni-Oldenburg.DE>
List: port-i386
Date: 10/19/1999 11:19:18
On Mon, Oct 18, 1999 at 09:15:11AM +0200, orione wrote:
> Started the standard procedure for installing NetBSD 1.4.1, all goes
> right... partitioning, newfs'ing, unpacking, devices.... mount partition
> and setup the first initializations for network, then reboot and.....
> AARRRGGHH! The bios stalls right after the auto-recognize of the ide
> devices!!!!!
Looks like a problem with the bootblock.. :-/

> So I try to do it by hand, correcting the disklabel, and doing all the
> install process by hand.... Please note that, since the first reboot, I
> had to boot telling the bios THERE ARE NO HD, DON'T CHECK PLEASE...
> nope, it won't boot.
Oh, I know this, I had the same problem some time ago. 

I think this happens when the bootblock on a harddisk is trashed in a very
weird way.  It doesn't matter, if you want to boot from this disk or not.
Because of this I needed *AGES* to find that out.

Overwriting the bootblock with a fresh one (with fdisk(8)) fixed it for me.
(But I still don't know, how the bootblock got coruppted).

> So I try to install FreeBSD, and I notice it recognize by default the
> right number of cylinder... and, well, it works. So I reinstall all with
> NetBSD 1.3.2, that believe to have an 8Gb hd... well, 10Gb less, but at
> the end it works. Mhm... then I tried to upgrade to 1.4.1, and it works.
> It booted.
> But.... I WANT all of my gigs!!
Ok, it boots now. Fine. Don't touch the bootblock and just "adjust" the
size of your disklabel and enlarge the size of the last partition (you
will loose everything in that partition) or make a new one for the rest
(use disklabel  -e -r [-C] disk for this).

{PS: next time mail us 
   a) the lines regarding the harddisk from the bootmessage (dmesg)
   b) the output of disklabel 
   c) the output of fdisk
Dies ist Thilos Unix Signature! Viel Spass damit.