Subject: Re: ncr lossage under 1.4.1
To: None <port-i386@NetBSD.ORG>
From: Jukka Marin <>
List: port-i386
Date: 10/18/1999 15:45:41
On Mon, Oct 18, 1999 at 08:28:25AM -0400, D'Arcy J.M. Cain wrote:
> Hmm.  I have been seeing this on a machine with the latest sources yet I
> have neither a tape or an ncr.  I am running an Adaptec 2940 and the drive
> mentioned is usually sd2.  I put it down to a flaky drive and was going
> to look at replacing it.  Could there be something else going on?  It
> certainly ran for years under BSDI and for a few months under W98 before
> I grabbed it.  Could it be a real hardware problem and NetBSD is simply
> more verbose about?

Dunno.  My HP is three days old, so I _think_ it should work.  And it works
just fine unless some kind of an error occurs.  This time, I had just
inserted a tape into the drive and the drive wasn't ready yet - and I
tried to access it.  It returned an error - and after that, every SCSI
command to the drive is failing.  Other SCSI units (a QIC drive and two
disks) are still fine.

Could it be that the DAT and the ncr driver got "out of sync" somehow and
the driver is now sending out crippled commands?  The drive worked just
fine for hours, so I tend to think that "any error condition confuses the
ncr driver until rebooted" :-I

I'm trying to build
to see if that version helps.