Subject: OK, I give up. Where's the mouse?
To: None <>
From: Henry B. Hotz <>
List: port-i386
Date: 10/15/1999 16:13:39
Excuse the newby question.  I've been over on port-mac68k for years and I
just got a used PC as the cheapest way to get another NetBSD machine with
decent performance.  Before I start whining let me say that the new
sysinst-based setup is way cool!  Much nicer than the Mac installer program
back when I was equally green on that platform.  Once I figured out how to
boot from the CD-ROM I had NetBSD 1.4.1 up and running in an hour or two
including the time to read the instructions and format the disk.

Now to the point:  the PC uses a QDI SpeedEasy Explorer II motherboard.
The no-name 3-button mouse worked fine under Windows before I installed
NetBSD.  It appears to be connected to the first serial port.  The only
mouse-related entries I see in dmesg are com0 and com1 which are the serial

When I try to start X it fails saying it can't open (find?  access?, I
forget) the mouse.  I would presume that means I need to put a different
device entry in XF86Config.  I've tried /dev/com0, wsmouse0, tty00, and
tty01, but they all return the same error.

Looking in /dev I see wsmouse[0-3], tty0[0-2], some bus-mouse entries, and
a ps2 mouse entry.  I do not see com0 or com1, and I can't create them with
MAKEDEV with the obvious arguments either.

Do I need to worry about the protocol at this point?  I assume I would get
a less abrupt error message if it were a protocol mismatch.  Sorry I can't
remember the exact error.  I'm at work and the machine is at home.

As a related question, why isn't the screen-based configuration program
included in the distribution?  The FAQ indicates it has some mouse tryout
screens that might be helpful in my situation.

Thanks for any help.  I'm not subscribed to this list, so please reply
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government., or