Subject: Re: ld for 1.4.1?
To: Sergey Ivanov <>
From: Frederick Bruckman <>
List: port-i386
Date: 10/13/1999 09:24:26
On Wed, 13 Oct 1999, Sergey Ivanov wrote:

>     I've installed NetBSD-1.4.1 i-386 snapshot of 99-09-06. I used only boot
> floppies of 1.4, but all sets was of this snapshot.

That snapshot is not of 1.4.1, it's of "current". The one you want is at

>     After installing I've changed only rc configured from NO to YES, exited
> from single-user mode to multiuser and tried xf86config. It reported "No
>     What does it mean? Where should I get this ""?
>     Then I've installed pkglibtool-1.2p2.tgz, with intention to get tcl, tk
> and after all XF86Config.
> But  tcl-8.0.5.tgz said it missed ldconfig. It reported: "/sbin/ldconfig not
> found".

I'm guessing you're trying to run aout binaries built for 1.4.1 with
the 1.4? elf kernel. It can be done, but you'd need to install big
chunks of 1.4.1 under /emul/aout anyway. You'll save yourself a lot of
trouble if you get the 1.4.1 base &c sets. On the other hand, the 'x'
sets that you downloaded evidently are built for 1.4.1, (otherwise
they would've worked on elf), so they should be fine.