Subject: serial line problem
To: None <>
From: Manuel Bouyer <>
List: port-i386
Date: 11/13/1998 18:08:21
I recently installed an UPS, which was sold with a few programs for
monitoring, including a linux/x86 version. So I installed it on a 1.3.2
box and got it to run. But I've a problem with how the serial line
is managed:
After a computer reboot, the UPS manager can't talk with the UPS: it seems able
to send datas but never get anything back (at last it's was what krace
showed). If I connect the UPS to a win95 machine with the win95 UPS manager
all is fine, and if I reconnect the UPS to the NetBSD machine the
linux UPS manager works now. I can kill and restart it, no problems.
But if I reboot the computer (I tried disable the ttyflags call in
rc, etc ...) the UPS manager doesn't work any more.
2 other ways I've found to unwedge the UPS line it to connet to the
tty with kermit and send breaks, then some datas, or switch off and on the
UPS (which makes it quite useless :).
I used stty -a on the tty when it works, and when it's wedged; the
outputs are identical.

Any idea of what could happen, and what kind of command I could use to
unwedge the line under NetBSD ? I'm really not an rs232 expert :)

Manuel Bouyer, LIP6, Universite Paris VI.