Subject: problem with snap-19981031 & snap-19981105
To: None <>
From: Tracy J. Di Marco White <>
List: port-i386
Date: 11/08/1998 18:29:16
I've gotten a new machine to play with, so I thought I'd install the new
snapshot on it.  I used sysinst on snap-19981031, and everything worked fine
(more or less) til I tried to bring it up with the new kernel, then it panic'd.

isapnp0: read port 0x203
extent_alloc_region: extent `ioport', size 0x0
panic: extent_alloc_region: bad size
Stopped in  at  _Debugger+0x4:  leave

c only tells me the operating system has halted.
I saw that snap-19981105 was available, so I grabbed the kernel on that to
see if it'd be any different, it wasn't.

It looks like the problem is with the sound card, likely the (IDE) interface
that isn't on it.   Suggestions?  I'm about to untar the snapshot and source
on my half working machine and see if I can compile a kernel for it, but
would appreciate suggestions.

The install kernel works fine, /kern/msgbuf output is:
NetBSD 1.3H (INSTALL) #1: Sun Nov  1 15:50:04 MET 1998
cpu0: family 6 model 3 step 3
cpu0: Intel Pentium II (686-class)
real mem  = 66715648
avail mem = 58499072
using 840 buffers containing 3440640 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o enabled, memory enabled
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x8086 product 0x7180 (rev. 0x03)
ppb0 at pci0 dev 1 function 0: vendor 0x8086 product 0x7181 (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o enabled, memory enabled
pcib0 at pci0 dev 4 function 0
pcib0: vendor 0x8086 product 0x7110 (rev. 0x01)
vendor 0x8086 product 0x7111 (IDE mass storage, interface 0x80, revision 0x01) at pci0 dev 4 function 1 not configured
vendor 0x8086 product 0x7112 (USB serial bus, revision 0x01) at pci0 dev 4 function 2 not configured
vendor 0x8086 product 0x7113 (miscellaneous bridge, revision 0x01) at pci0 dev 4 function 3 not configured
vendor 0x102b product 0x051b (VGA display) at pci0 dev 7 function 0 not configured
isa0 at pcib0
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
wd0 at wdc0 channel 0 drive 0: <QUANTUM FIREBALL SE6.4A>
wd0: using 16-sector pio transfers, lba mode
wd0: 6149MB, 13328 cyl, 15 head, 63 sec, 512 bytes/sect x 12594960 sectors
wd0: using 32-bits pio transfers
wd0: PIO mode 4, DMA mode 2, UDMA mode 2
wdc1 at isa0 port 0x170-0x177 irq 15
atapibus0 at wdc1 channel 0
we0 at isa0 port 0x280-0x29f iomem 0xd0000-0xd1fff irq 9
we0: WD8003E Ethernet (8-bit)
we0: Ethernet address 00:00:c0:d4:70:17
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
pc0 at isa0 port 0x60-0x6f irq 1: color
pc0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: read port 0x203
isapnp0: <AZT1008 PnP SOUND DEVICE, AZT0500, , IDE CDROM DISAB> ignored; resource conflict
isapnp0: <AZT1008 PnP SOUND DEVICE, AZT1008, , AUDIO> port 0x220/16,0x388/8,0x534/4 irq 5 drq 1,3 not configured
isapnp0: <AZT1008 PnP SOUND DEVICE, AZT2001, , MPU401 MIDI> port 0x330/2 irq 9 not configured
isapnp0: <AZT1008 PnP SOUND DEVICE, AZT3001, , GAME PORT> port 0x200/8 not configured
biomask c040 netmask c240 ttymask c242
md0: internal 1537K image area
boot device: fd0
root on md0a dumps on md0b
root file system type: ffs

Tracy J. Di Marco White
Project Vincent Systems Manager