Subject: Re: new wdc/wd loses interrupts?
To: Manuel Bouyer <>
From: Chris G. Demetriou <>
List: port-i386
Date: 12/19/1997 15:48:38
Manuel Bouyer said (a month ago):
> On Nov 19, Chris G. Demetriou wrote
> > Anybody else seeing problems with the current (1.3_ALPHA) wdc/wd
> > drivers?
> > 
> > I've getting lost interrupt messages every so often on my laptop.  It
> > _doesn't_ appear particularly related to suspend/resume requests,
> > etc., it just happens randomly while i'm using the system (and makes
> > the system utterly unusable with the current version of wdc.c 8-).
> > 
> > I've tried revisions (the current one) and 1.6.  The former
> > fails in the way described, the latter works correctly (or, as
> > correctly as it always had 8-).  In my kernel source tree, i've
> > switched back to the old version of _only_ that file, i.e. the
> > problems do seem completely dependent on the changes between those
> > revisions.
> > 
> > Anybody else seeing anything?
> Well, I'm using it on 486, 586, 686 and 6x86 without problems.
> But laptops have often "interresing" behaviors :)
> Could you give an example of the timeout message (in, the timeout
> message is a bit more verbose).
> Also, is the same as 1.8. Could you try rev 1.7 ? This would narrow
> down a bit the changes which caused that.

I finally found some time to look into this further.

When building a new kernel for other reasons, I accidentally compiled
the current version of the driver into one of my laptop kernels, and
it worked.  Looking back at the kernels which worked and which didn't,
it seems (i've not really verified this) that the problem only occurs
then APM debugging is turned on and told to spit out printfs about

I might try to confirm that's the circumstance in which the problem
occurs, and track down which rev of the driver the problem started
showing up in.  However, I might not have time.