Subject: 1.3Beta
To: None <port-i386@NetBSD.ORG>
From: Robert.V.Baron <>
List: port-i386
Date: 12/02/1997 14:58:00
I decided to pick up the beta and run with it.  The old install
interface worked reasonably well, except I did not know if there
is a program that could be run afterwards to set up the rc.conf.
Why doesn't the GENERIC kernel include pms0 -- how can you run X.
By the way is there a 3.3.1 specifically for 1.3 (or an afs for it).

I was sort of disappointed with the sysinit interface and think that
it needs a bunch of work to make it friendly/useable for niave users.
Some of these points have been raised earlier but are not yet fixed.
My comments (somewhat stream of consciousness) follow:

-------------------- trial one

0. I did not look too hard but I could not find an INSTALL document

1. The program name should be something more understandable
   than sysinst -- howabout install or menu_install and maybe
   the existing install can be install.old

2. In sysinst, most menu's end with an x (exit) option.  This
   is really gets you to the next menu so why not call it n (next).

3. When you net install, you should be allowed to not specify a
   nameserver or gateway.  Then you would use the ip addresses to
   ftp or nfs to.

4. As someone remarked, if ftp fails the messages blast by so fast
   that you can not tell what happened.

5. There should be an option that lets you go out and do the ftp's
   by hand and then go back in and do the extracts.

6. I messed up a bit and reloaded several times (on the same boot),
   once from the initial menu option -- specifying the disk geometry
   options and several times from the upgrade menu option.  I also
   had an old disklabel in the NetBSD partition when I started.  But I did
   get the system to extract into root & /usr.  When I rebooted, I 
   discovered that my MBR was 0.  THIS SHOULD NEVER BE POSSIBLE.  The 
   install should always check to make sure that the mbr looks plausible
   before it is written.  Luckily, I had the contents written down, so
   I could use pfdisk and fdisk /mbr to recover.

   It looks like the disklabel never made it back to disk.  When I rebooted
   the a slice was the old disklabel info, but the a fs was much bigger
   than the slice, hmmm.

7. I also tried a simple install (like in days of old).  It worked fine
   except there was no hint of were/how I was to go to get a kernel.

---------------------- trial two.

   I "cp sysinst /dev/wd0a" to clean things up and restart.

1. It tells me that:
	real geom: 2650 51 63
        bios geom: 530 255 63
   this looks ok.  But the real geometry is really just a figment of sysinst.
   (I presume that it is created because using 255 63 freaks out newfs which
    then wants 32K blocks with 4k frags)

2. Now it wants me to choose real geometry or disklabel geommetry
	disklabel: 2650 51 63
        real geom: 9042 15 63
   THIS IS VERY BAD.  First it is confusing, since real in 1. and real in 2.
   are not the same.  SECOND, if you use 15 63, you will never get these blocks
   to align with the disk geometry that NT, win95 or anything else is using.
   If you use the 51 63 you are an integral fraction of the BIOS size, if you
   use 15 63 the math gets way harder.

3. I choose to specify geometry in cyl's then choose the standard layout.
   (can't believe netbsd is 500+ meg these days.)  When it shows the layout,
   it uses meg.  I want cyl so I can make sure I am not breaking anything!

4. After 3, if you do "change a partition", and go to set new allocation size
   you can choose cyl and it now sticks.

5. There are a bunch if errors about removing / from absolute path names in archive.

6. We'll install from  But this is taking forever.  Time to abort.
   sysinst realizes that we are aborting and I eventually make it to the main menu.
   I try an upgrade, but the fs's are still mounted so this fails.  Time to exit,
   unmount, and sysinst again

7. I decide to do a "local" upgrade.  It chooses sd0 as the Device which is a
   real device in my machine, but everything so far has happened on wd0.  So
   why do I really want to use it instead?

8. I specify wd0e and directory /usr/INSTALL -- it seems to want to mount 
   /usr/INSTALL on wd0e -- how silly.  /usr/INSTALL is where the file are.
   Actually, I've not put them there yet, and since there is no "go to shell"
   option, I guess I'll have to move them over and restart -- sigh

9. But putting the .tgz files in /usr/INSTALL doesn't work either.  It refuses
   to find them.

a. We exit, unmount, and restart again.  This time something goes wrong
   "mv /mnt/etc /mnt/etc.old".  The script aborts and now when I type I
   don't see the echo.  (stty echo fixes this.)

b. Well, it's time to bail and do a simple "install" installation.  But before
   I do that, I did one last "disklabel wd0".  The root is 277Meg, swap is 258Meg
   and /usr is the rest 561meg.  Why is root so big?  Further, I have 128Meg of
   primary memory not to swap.  I don't want to waste 258meg of disk.


1. I use a root of 32Meg, swap of 80Meg, usr 128Meg and the rest usr1
   After installing the tgz's root has 17Meg left and usr has 41Meg.  So
   why all the space above.

2. /etc/rc.conf was not set up is there a tool that generates fills it in.

3. I ran Configure.  It asks about interfaces strip0, strip1 and eon0.  What
   are these -- strip is metricom, and eon0 -- but I don't use either should
   Configure ask about it.

4. I want to get into X as quickly as possible since I need a gui.  The 
    generic kernel does not include a pms0 driver -- huh?