Subject: re: XFree86 3.1.2 and NetBSD/i386 1.2
To: Brian Stark <>
From: None <>
List: port-i386
Date: 11/23/1996 09:34:16
Hello Brian,

I do have sporadic keyboard problems which I havent tracked down yet,
but generally the combination is OK.

Can you run X from a shell prompt (startx)? Is getty disabled on the
console? Have you tried putting some debug logging in xdm/Xsession
and/or ~/.xsession?


Rex McMaster                  

Brian Stark writes:
 > Hello,
 > I am wondering if anyone has been able to get XFree86 3.1.2 running
 > with NetBSD/i386 1.2? 
 > I have recompiled my NetBSD kernel with the XSERVER and UCONSOLE options.
 > As root, I can enter "xdm -nodaemon" and a login screen for X Windows 
 > pops up. At this point I get stuck -- no matter what I enter for the 
 > user name and password (valid userid & password or not), the screen goes 
 > blank, and then a few seconds later the screen reappears and again 
 > prompts me for a user name and password. Attempts at CTRL-ALT-BACKSPACE 
 > fail to stop the server. I have also recompiled the X server, but still I 
 > get the same result. The xdm-errors file shows no errors. The only way I 
 > can safely recover from this is to start a background process like: 
 > "sleep 240; shutdown -r now".
 > At this point I'm not sure if I am overlooking something (obvious?) that 
 > needs to be done to NetBSD or to XFree86.
 > I've looked through the release notes for NetBSD and XFree86 and I don't 
 > see anything describing my situation.
 > Ideas, anyone?