Subject: Re: PPP problems
To: Nathaniel D. Daw <>
From: Brian C. Grayson <>
List: port-i386
Date: 11/17/1996 16:46:38
Perry wrote:
> I suspect you are having serial problems. Try the unofficial com
> patches on the FTP site in arch/i386. If they help, that probably
> means that its yet another problem with the serial driver.

Nathaniel D. Daw wrote:
> I had this precise problem when I started using PPP with
> NetBSD-current around May. Data is being dropped out of large packets
> when leaving your system, which is why telnet works fine (except
> things like pasting from the X clipboard), but bulk file and mail
> transfers off the machine fail. To see if this is what is happening,
> try ping -s with various sizes up to the interface MTU. 

  Well, I tried both things, and either will apparently fix the
problem:  the patches to icu.s and com.c, or adding 'mtu 300' to
/etc/ppp/options.  And, doing both will also work, as expected.
The mtu option doesn't seem to have very good performance, BTW
(around 50-70% transfer rate of the patched com fix), from my
quickie test (ftp'ing a 100K binary file).  Since the kernel
patch works, I didn't bother trying to find the optimal mtu
value.  So I'll stick with the kernel patch.

  SLIP also worked fine, by the way, without any tweaking.

  Thanks for the help, guys!  I'm back in action...

Brian Grayson (
Graduate Student, Electrical and Computer Engineering
The University of Texas at Austin
Office:  ENS 406       (512) 471-8011
Finger for PGP key.