Subject: two problems installing 1.1 or 1.2, floppies and memory
To: None <port-i386@NetBSD.ORG>
From: Andrew Brown <>
List: port-i386
Date: 11/13/1996 12:14:54
i've installed netbsd more times than i can count (or more than i care
to count right now).  all of a sudden i'm having real trouble getting
it so boot the install floppies.  yesterday (to give you a numbers run
down) i tried:

* four (4) downloads of the floppy images from (1.1 & 1.2)
* four (4) machines writing the images out to floppy disks
* twenty (20), at least, different floppies for the kc*.fs images (this
  includes several different vendor types of floppies, not all the same
* three (3) machines trying to boot any of them, on of which is already
  installed (i just wanted to check my sanity which is apparently missing)
  1) a machine that needs netbsd 1.2 installed
  2) a machine comfortably running winblows 3.1 (as comfortable as that
     isn't), just for checking to if the disks would boot at all
  3) a machine already quite happily chugging along on netbsd for about
     a year now (just another control test)
... and on 1) of those three machines ...
* three (3) different 3.5 drives (maybe the first one was broked?)

with no good results at all.  what i did get:
* boot blocks do not load at all, machine boots dos (bleah!)
* boot blocks load and can't find /netbsd, /onetbsd, or /netnsd.old
* kernel starts to boot and "twiddle" stops after the third twitch
* kernel starts to boot and then tells me

     Error: C:6****** H:0 S:8

  in between each "twiddle", where 6****** is some number in the six
  million something range (this is not a joke, i just don't recall the
  actual number off the top of my head)

i've tried old disks that used to boot just fine and they're skwewy
too.  at this point i'm rather confused.  some points...

* the images were all downloaded from the site in binary mode
* all images were dd'ed out to /dev/rfd0c (and then /dev/fd0c when
  /dev/rfd0c didn't seem to help) with bs=10240 (just as i've always
  done it)
* all images were subsequently dd'ed back into the system from the
  floppy disk just to check and were usually identical to the original
  image (in cases where this was not so, the floppy was thrown into the
  corner of the room where all broken things go)

the machine that needs netbsd installed
* 32-96M ram
* two onboard ide controllers (second one disabled)
* ide hard drive (~2g, this customer doesn't believe in scsi?!)
* pentium 133
* com2 disabled in cmos, lpt1 & lpt2 disabled in cmos
* (i can get more specs if i've missed something crucial but the
  machine ain't in front of me right now)
also had it's memory rotated and changed, and wants to run with 128M
when this work is done.  which brings me to my second problem.

i took an existing 1.1 system (running fine) and upgraded it to 1.2
(customer wants it to run with 128M).  everything was fine until i
built the 1.2 kernel for 128M (with that extmem config option).  it
crashed after two minutes.

  me: looks like it's up.
  other guy: but when's it gonna crash?
  me: (looks at machine, watches it panic) about now.

after this, no matter what we did to the kernel, it wouldn't stay up
more than a minute if it got past rc.  if i booted it single user, it
panicked as soon as i did anything to the root filesystem requiring
blocks to be allocated or deallocated, eg, touch and rm (of zero length
files) worked, but cp and rm (of non-zero length files) would panic.
this is after we
* figured out that EXTMEM_MEM wants the size in k, not bytes or megs
* added NKMEMCLUSTERS=2048-8192 (we varied it) to the config file
* added NMBCLUSTERS=1024-4096 to the config file
* changed NKPDE in ~1386/include/pmap.h (this, if you end up having to
  change it like lots of people seem to have been doing, should really
  be a config option, no?)
* rotated the memory back to 64 and changed simms with other machines
* booted from the install floppies (yes, they worked last week), tar'ed
  root out to somewhere else, newfs'ed it (we thought it was fubar) and
  tar'ed it back into place.
* erased the swap space (maybe swap was dirty and needed to be cleaned?)

luckily i keep all my old kernels (in /NetBSD/config#version) so that
i can jump back to any old kernel.  that particular machine is rather
stable right now, ut i still don't think it's fully recovered from having
such a gross shock to its system.

help?  please??  anyone???

|-----< "CODE WARRIOR" >-----| (TheMan)        * "ah!  i see you have the internet                               that goes *ping*!"      * "information is power -- share the wealth."