Subject: Pinacle Micro Vertex2.6 MO Drive
To: None <port-i386@NetBSD.ORG>
From: Aron T. Roberts <>
List: port-i386
Date: 09/16/1996 00:35:09
Potentially stupid question??  Maybe... but i have yet to achive

I am trying to get my NetBSD 1.1/i386 box to recognise my PinnacleMicro
Vertex 2.6gig MO drive. The SCSI adapter is a Buslogic 946C.

I have tried various Hardware configurations from trying to masqurade as a
plain old hard drive to optical/removable setups.  (netbsd always
correctly identifies it as a removeable drive)

It is partially recognized on boot then i get (from the logs)

bt0 targ 4 lun 0: <PINNACLE, Vertex 2.6GB, 1.13> SCSI2 0/direct removable
sd1 at scsibus0: 1243MB, 9347 cyl, 1 head, 136 sec, 1024 bytes/sec
probe(bt0:4:1): error code 7
probe(bt0:4:2): error code 7
probe(bt0:4:3): error code 7
probe(bt0:4:4): error code 7
probe(bt0:4:5): error code 7
probe(bt0:4:6): error code 7
probe(bt0:4:7): error code 7

digging through the source i *think* error 7 is DATA PROTECT butt hen i am
usually wrong :)

at anyrate I checked the only thing data protect meant to me and that
wasn't it.

I was outta my league as soon as it had errors....

the only thing i haven't tried was scsi formatting the disk to blow away
old crap but A: I dunno if it matteres at the device recognition stage and
B: I am trying to do this remotely and can't think of anything other than
the adapter to do that for me.

any pointers to relevant info appreciated

aron roberts
Seattle, WA  USA