Subject: COMPAT_FREEBSD / FreeBSD GIMP binary problem
To: None <port-i386@NetBSD.ORG>
From: Colin BRADLEY <fox@CS.McGill.CA>
List: port-i386
Date: 09/07/1996 16:59:01

  I've been trying to get the FreeBSD GIMP binary working under

  The GIMP is an image manipulation program available at I have nothing to do
  with it, except that I'd like to use it.

  Here's what happens when I run it:

622 {fox@ferratti} [/scratch/pkgs/FreeBSD/gimp-0.54-2.1/gimp] ./gimp
./gimp fatal error: could not allocate 1874840296 bytes

  I don't have that much memory :)
  Here's the output from the FreeBSD ldd:

623 {fox@ferratti} [/scratch/pkgs/FreeBSD/gimp-0.54-2.1/gimp] ldd-freebsd ./gimp 
        -lXt.6 => /usr/X11R6/lib/ (0x10165000)
        -lSM.6 => /usr/X11R6/lib/ (0x101b3000)
        -lICE.6 => /usr/X11R6/lib/ (0x101bb000)
        -lXext.6 => /usr/X11R6/lib/ (0x101cd000)
        -lX11.6 => /usr/X11R6/lib/ (0x101d5000)
        -lm.2 => /usr/lib/ (0x10250000)
        -lc.2 => /usr/lib/ (0x10268000)

  Has anyone seen this problem before? Is this a COMPAT issue? 
  The last few lines of a kdump are as follows:

 17105 gimp     RET   read 5388/0x150c
 17105 gimp     CALL  fstat(0x1,0xf7bfd2f0)
 17105 gimp     RET   fstat 0
 17105 gimp     CALL  break(0x1a2ffc)
 17105 gimp     RET   break 0
 17105 gimp     CALL  ioctl(0x1,TIOCGETA,0xf7bfd32c)
 17105 gimp     RET   ioctl 0
 17105 gimp     CALL  write(0x1,0x19e000,0x38)
 17105 gimp     GIO   fd 1 wrote 56 bytes
       "./gimp fatal error: could not allocate 1874840296 bytes
 17105 gimp     RET   write 56/0x38
 17105 gimp     CALL  exit(0)

  Could anyone point me at what to look at in the compat code, 
  or suggest otherwise?

  Alternatively, how would someone who has the Motif libs for 
  NetBSD/i386 feel about building and making a binary available?

  The COMPAT_LINUX version also, dies but I forget the particulars.
  The FreeBSD version(s that I've tried) seems to get further.

  Thanks for any suggestions,


                                       -- Colin Bradley