Subject: Kernel compile problems
To: None <port-i386@NetBSD.ORG>
From: Sean Conley <>
List: port-i386
Date: 04/10/1996 00:53:22
Thanks in advance to anyone that can assit with this....

I'm having a problem in trying to build a new kernel.  Here's what 

% cd /sys/arch/i386/conf
% vi CONLEY   #(make changes)
% config CONLEY
% cd ../compile/CONLEY
% make depend   #no problem so far
% make
making sure the kern library is up to date
cd: can't cd to lib/kern
***: Error code 2


There is an .include statement in ../compile/CONLEY/Makefile which 
calls in /sys/lib/kernlib/  This seems to be the make which 
generates the error message.

There is in fact a ../compile/CONLEY/lib/kern directory and 
permissions don't seem to be the problem.  The directory is empty.

I get the same results when I try to compile a GENERIC kernel, and 
I've even tried removing all files under the ../compile/CONLEY 
directory, and going through the procedure again.

The odd thing is that I have compiled a kernel on this system before. 
 I cannot find my notes on the compile the worked, but I don't think 
I'm doing anything differently.  I don't recall making any system 
changes that would cause this error.  Any ideas?

Again, thanks in advance.
Sean Conley