Subject: Re: random core dumps when compiling...
To: Ernst J. du Toit <>
From: Andre Skarzynski <>
List: port-i386
Date: 05/15/1995 08:43:01
Ernst J. du Toit wrote :
> Mark Steven Tamola wrote:
> > 
> >[ describes problem with random errors 139, signal 11 and core dumps
     with Cyrix processor ]
> > netbsd-1.0/i386, the random core dumps would only happen if i had the 
> > DUMMY_NOPS option in the kernel, but under -current, i now get the core 
> > dumps all the time.
> > 
> > has anyone out there with a cyrix processor had the same problems?  i 
> > don't want to move back to -1.0 as i really enjoy the new stuff in 
> > -current.  can anyone sympathize with me?  am i forced to fork out the 
> > dough to by a new motherboard?
> > 
> I know this might seem strange, but try and flip the jumper on your board
> to tell it you have an INTEL (or INTEL/AMD) processor... my girlfriend's
> box with NetBSD-current on it got so stable I could build a kernel without
> sitting infront of the box all the time. Her box is still running the SAME
> kernel and binaries I put on BEFORE trying to build a kernel (I've got the
> kernel with the CYRIX_CACHE_WORKS and CYRIX_CACHE_REALLY_WORKS lines take
> OUT of the config on standby now incase the box acts up - but so far
> nothing)


I am using an IBM BlueLightening 486DX2 which is a Cyrix486DLC chip. The M/B
I have is configured for Intel, anyway, I was running a kernel with the options
CYRIX_CACHE_WORKS ans CYRIX_CACHE_REALLY_WORKS enabled. The machine worked 
extremely well, and fast (I heard that the IBM chip is supposed to have more
cache but I can't confirm). Anyway I have build many things, and only once did
I see an error, until I started building a large GENERIC kernel, Oh yes, I 
am using NetBSD-current, then I started to get an error, just once mind you,
"bad addresss : signal 1", but only once. I then build the kernel again, later,
and then got a "random error code 139" with a core dump, also once, and only
when building a large GENRIC kernel, but it happens only once in the build,
but is repeatable.

I then removed the option CYRIX_CACHE_REALLY_WORKS form my kernel, so that the
Cyrix cache now works in a hold flush mode, and build the large GENERIC I was
trying. No problems after that. worked like a dream.

Just my pennies worth.

Andre B. Skarzynski  -- Information Technology, University of Stellenbosch --   ------- Tel: +27 21 8084293 Fax: +27 21 8084102 --------