Subject: Re: SMC Elite16C Ultra Memory Corrupt?
To: None <>
From: Brian Moore <>
List: port-i386
Date: 03/29/1995 01:19:08
I've actually seen this bug come up in an even weirder way.  I installed an
entire system via FTP with a SMC Elite16C Ultra at CC00 using ed2 and a BT946
at C800.  But when I rebooted the machine it gave me the NIC errors that have
been discussed.  Checked for memory caching in the BIOS, but it was all shut
off.  Finally rebuilt a kernel with ed0 pointing at d800, and switched the card
to d800 and evrything worked fine.  No idea why the files would be able to
come down perfectly using the boot floppy and then the Ethernet card would go
south after copying the kernel and rebooting, but maybe these are related?

--Brian Moore

misconfigured, but now
> >>I've just tried to install an SMC Elite 16C Ultra card into my system.
> >>It's recognised with
> >>
> >>ed0 at isa0 port 0x300-0x31f iomem 0xd800-0xdbfff irq 9: address
> >>00:00:c0:cc:a1:98 type SMC8216/SMC8216C (16-bit) aui
> >>
> >>on bootup. (This though the card is configured for the 10baseT
> >>port.)Unfortunately, when I ifconfig it with my ethernet address all I get
> >>is "NIC Memory Corrupt - invalid packet length 0". I've tried irqs 2 and
> >>10, ports 0x300 and 0x340, and memory addresses 0xcc000, 0xd0000 and
> >>0xd8000. Another identical card gives the same results. I've also tried
> >>various combinations of link0, link1 and link2 (it has link0 set by
> >>default when I check it after first booting).
> >Hi! I've seen this on several system's, 486 or better, with cache. You need 
> >go into your Advanced BIOS Settings and make sure the block that the Etherne
> >board lives in is NOT being cached. Most machines allow your to disable cach
> >for certain regions of memory space.
> Actually what's much more likely is a very strange conflict between
> the floppy driver (fd) and the ed driver.  If you are using a kernel
> (like one of the boot floppy kernels) that has two floppy drivers
> configured (fd0 and fd1) and you only have one floppy drive, then you
> will receive that error on ifconfig.  Must be something like the fd1
> driver grabs the ethernet card or something...very bizarre.
> The fix: either get another floppy drive or rebuild yourself a kernel
> with only one floppy drive configured in it.  Some people on this list
> might also be able to build you a kernel.  I bootstrapped with a
> friend's floppy drive until I could build myself another kernel.
> (Yeah I know this sounds like a funky bug but I know of at least 2
> other people besides myself who've seen it).
> Alexandra Ellwood
> (