Subject: SMC Elite16C Ultra Memory Corrupt?
To: None <port-i386@NetBSD.ORG>
From: Curt Sampson <>
List: port-i386
Date: 03/28/1995 02:06:30
I've just tried to install an SMC Elite 16C Ultra card into my system.
It's recognised with

ed0 at isa0 port 0x300-0x31f iomem 0xd800-0xdbfff irq 9: address
00:00:c0:cc:a1:98 type SMC8216/SMC8216C (16-bit) aui

on bootup. (This though the card is configured for the 10baseT
port.)Unfortunately, when I ifconfig it with my ethernet address all I get
is "NIC Memory Corrupt - invalid packet length 0". I've tried irqs 2 and
10, ports 0x300 and 0x340, and memory addresses 0xcc000, 0xd0000 and
0xd8000. Another identical card gives the same results. I've also tried
various combinations of link0, link1 and link2 (it has link0 set by
default when I check it after first booting).

I've probably spent five hours mucking about with this now, and
obviously I'd really like to get it to work. :-) Has anyone any clues
to help me out here?

Curt Sampson		Opinions are mine,
Fluor Daniel Wright, Ltd. 604 488 2226		not Fluor Daniel's.
1075 W. Georgia Street
Vancouver, B.C., V6E 4M7	 	De gustibus, aut bene aut nihil.