Subject: Re: Install/Bootup/MS-DOS problems
To: None <>
From: Chris Perleberg <>
List: port-i386
Date: 03/27/1995 10:06:42
>    1) I can't boot from the HardDrive.  When trying to boot from
>       wd(0,a)/netbsd, an error appears "invalid format".  The NetBSD
> That would indicate the kernel on the hard disk is corrupted.  Did you
> actually `halt' the machine after copying the kernel, or did you just
> press the reset button?

I have followed the procedure of booting up on the kernel floppy, and
performing "copy_kernel", doing halt, and then hitting a key to restart.
No luck.  I tried renaming netbsd to netbsd.bak (in case netbsd was on top
of a bad disk sector), and doing "kernel_copy" again, halting and restarting,
but no luck.  I tried copying the kernel to netbsd.old from the floppy as
well, but receive the same error "invalid format".  Not sure if it would be 
much help to get a new kernel disk since I can boot off it on a floppy fine....

For the information, I'm using a WDC31000 1 Giga disk (2100 cylinders, 16
headers, 63 sectors/track).  I've got msdos on Cyl 0-1021, and BSD on 1023
to 2098.  I left a few cylinders free since the *BSD FAQ mentioned that
disklabel needs some space or it trashes the MS-DOS stuff (and it's too much
effort to actually try to test these statements :-).

>       % mount /dev/wd0f /mnt/msdos
>       /dev/wd0f on /mnt/msdos: Incorrect super block.
> Try:
> mount -t msdos /dev/wd0f /mnt/msdos

Thanks!  I can now mount the msdos partition fine!

	Chris Perleberg