Subject: Re: PS/2 mouse, netbsd-current and XFree 3.1.1
To: None <>
From: Tom Ivar Helbekkmo <>
List: port-i386
Date: 03/16/1995 07:45:53
On Wed, 15 Mar 1995 wrote:

>    ->Configure the PS/2 mouse in XF86Config as a `Busmouse'.
>    Doesn't work for me.  DECpc 486DX2 LPV+, NetBSD 1.0 or -current as of 3/11/95
> What do you *mean* by `doesn't work'?  That tells me very little.

I've got a general mouse problem that might be related to this.  I'm
running NetBSD-current as of two weeks ago; source tars fetched from on Sunday, March 5, and XFree86 3.1.1 (X11R6pl11 plus
the XFree86-3.1.1.diff patches applied).  Everything looks good on my
DECpc LPx 433dx with a DEC S3-based VESA graphics board, except that
the mouse buttons don't behave properly:

Running with twm, I get buttons 1, 2 and 3 to all work right with a
Logitech mouse configured as "busmouse" on "/dev/pms0", but not with
modifiers; I can't get Meta-mouseclicks to work for twm, and I can't
get the Ctrl-mouseclicks to open xterm menus.  Within various
applications, behavior is even stranger:  If I run Ghostview 1.5, I
can use mouse button 1 in the display part of the window to select and
enlarge portions of the display, and I can use the mouse buttons in
the scroll bars to move the image -- but I can't open the pull-down
menus; nothing happens when I press mouse buttons on the menu fields.
Inside TK-based applications, mouse buttons don't seem to work at all.

I tried with a Microsoft serial mouse on a COM port, but the behavior
was exactly identical with that configuration, so I assume it must be
a problem with XFree86, not the pms driver.

If I run the same applications on the same system, but with display on
another system, an i386 running NetBSD 1.0 and XFree86 3.1, everything
works fine.  If I run an application on the other system, with display
on my system, I do get the problems.  Thus, it seems to be the Xserver.

Hope this helps -- and that someone can give me a hint or so here!  :-)