Subject: Tape drive problems
To: NetBSD bugs <>
From: Barclay, Alex <>
List: port-i386
Date: 12/06/1994 13:43:00
Hi there,

I'm having some trouble with a tape drive connected to my NetBSD i386 

The tape drive is a Wangtek 5099EN connected to what seems to be an Everex 
clone of a Wangtek PC36 controller.

During a transfer (read or write) at some time I get an error:
 /netbsd: dma channel 1 not finished

The wt driver reports during autoconfig

 /netbsd: wt0 at isa0 port 0x300-0x301 irq 9 drq 1: type <Wangtek>
Further information

The place where the problem occurs seems to be random, the only repeatable 
aspect being that it _will happen sometime_ unless you are lucky to be 
writing a really small save set.

The size of the blocks doesn't matter either I've tried the following tar 

tar cvfb /dev/rwt0 40 ......
tar cvfb /dev/rwt0 20 ...... (is this the default)
tar cvfb /dev/rwt0 1 ......

All have the same result.

Sometimes the process will hang in the kernel although removing the tape 
usually releases this, other wise the process may continue to write the 

What is happening??

This has been happening with 1.0BETA, 1.0 and 1.0-current (last weekend)