Subject: No keyboard with current Re: upgrading distribution
To: port-hpcsh list <>
From: Michael Wileman <>
List: port-hpcsh
Date: 08/27/2005 21:22:03
On Fri, 26 Aug 2005, Valeriy E. Ushakov wrote:

> On Fri, Aug 26, 2005 at 15:32:46 -0400, Michael Wileman wrote:
>>> No need to reformat the card, just untar the sets except the etc.tgz
>>> in single user mode (or on another machine) and run postinstall(8).
>> So you mean untar them OVER the current installation?
> Yes.
>> And can I run postinstall also on the other machine,
> You should be able to, e.g. standard netbsd (cross) build runs it.
>> or it must be run on the 680?
> It might be easier to run "na{t,}ively" on the 680.  Less options to
> worry about ;).

Installed all of the sets except etc.tgz and xetc.tgz, then loaded the 
CF and booted. Booted fine, but I can't log in from the console. In 
fact, I don't seem to have any keyboard at all. Booting once without 
the network card, I was unable to type ^C to make the kernel stop 
trying to set an nfs swap.

I was able to boot into single-user mode and run postinstall, and now 
I can log in via ssh over the network with the current kernel.

Just for kicks I tried using the 3beta kernel, which worked with my 
old userland, but I get an error:
panix: init died (signal 0, exit 1)
kloader: kernel file name: /netbsd
kloader: namei failed (/netbsd)
syncing disks... done

Then it locks up hard, so it seems that the 3-stable kernel doesn't 
work with the current userland.

Could someone who is running current download the Aug24 kernel binary 
and see if it works for them, so I will know if it is worth it for me 
to keep trying to get this working?

It probably doesn't matter, but here are some errors I got after 
running postinstall. I also noted that I seem to be using a lot more 
space in / than before, even after postinstall cleaned things up.


Source directory: /mnt/newetc/
Target directory: /
defaults fix:
         /mnt/newetc//usr.sbin/pf/etc/defaults is not a directory; 
skipping check
mtree fix:
gid fix:
         Missing groups [NOT FIXED]: _pflogd authpf
uid fix:
         Missing users [NOT FIXED]: _pflogd
periodic fix:
rc fix:
pam fix:
ssh fix:
         (Checking for moduli from /mnt/newetc//etc instead of 
x11 fix:
         Migrate /usr/X11R6/lib/X11/fs to /etc/X11/fs [NOT FIXED]
         Migrate /usr/X11R6/lib/X11/lbxproxy to /etc/X11/lbxproxy [NOT 
         Migrate /usr/X11R6/lib/X11/proxymngr to /etc/X11/proxymngr 
         Migrate /usr/X11R6/lib/X11/rstart to /etc/X11/rstart [NOT 
         Migrate /usr/X11R6/lib/X11/twm to /etc/X11/twm [NOT FIXED]
         Migrate /usr/X11R6/lib/X11/xdm to /etc/X11/xdm [NOT FIXED]
         Migrate /usr/X11R6/lib/X11/xinit to /etc/X11/xinit [NOT FIXED]
         Migrate /usr/X11R6/lib/X11/xserver to /etc/X11/xserver [NOT 
         Migrate /usr/X11R6/lib/X11/xsm to /etc/X11/xsm [NOT FIXED]
wscons fix:
makedev fix:
         (Checking for MAKEDEV from /mnt/newetc//dev instead of 
postfix fix:
         (Checking for postfix scripts from /usr/share/examples/postfix 
instead of /mnt/newetc//gnu/dist/postfix/conf)
obsolete fix:
sendmail fix:
hosts fix:
postinstall fixes passed: mtree periodic rc pam ssh wscons makedev 
postfix obsolete sendmail hosts
postinstall fixes failed: defaults gid uid x11