Subject: Re: Key auto-repeat not working in X
To: Christer Andersson <>
From: Michael Wileman <>
List: port-hpcsh
Date: 08/18/2005 16:48:31
> Sure, but I haven't got many init files. I have tried the bog
> standard twm, and no particular .xinitrc, just the standard xinitrc
> in /etc/X11/xinit.

Do you have a .Xdefaults directory, and is anything in there. I wonder 
if we have a different default setup.

> I have also tried with evilwm, and a .xinitrc I am attaching.
> Evilwm doesn't use any other init file. I don't seem to have any
> XF86Config or xf86config. I guess it runs on default values.

I just realized I am confusing the Jornada with my x86 machines. Of 
course it has no XF86Config.

> I am starting X with startx as an ordinary user.
> Key repeat works in both the above cases for me. I _think_ my
> userland is 3BETA, from a binary snapshot.

This is weird. Now I am wondering if perhaps it is something in the 
server setup. I know I get some errors on startup, and one of them 
tells me X is using the default console keyboard. I'll see if I can 
find the exact error next time I start up, and maybe someone will have 
an idea.