Subject: Re: trouble installing NetBSD 2.0 on NEC MobilePro 780
To: Andrew L. Gould <>
From: R O'Connor <>
List: port-hpcmips
Date: 01/02/2005 14:00:05
Andrew L. Gould wrote:

>I've been having trouble installing NetBSD 2.0 on NEC MobilePro 780.
>Attempt #1:
>I was able to get the 2GB Microdrive partitioned in the CF port.  I had 
>copied the contents of the installation CD onto a 128 MB memory card 
>which was in a PCMCIA adapter/slot.  (This worked when I installed 
>1.6.2 onto a 1GB microdrive in the past.)  I was able to mount the 
>memory card; but I got the following message when the installer tried 
>to untar kern-GENERIC.tgz:
>panic: TLB out of universe: ksp 0xc2991fb8  epc 0x8014aee8  vaddr 
>Stopped at 0x801cdeb8:   jr   ra
>                bdslot:  nop
>Attempt #2
>Guessing that the kernel file may be corrupted, I cross compiled a 
>kernel on a x86 machine, tar-gzipped it and replaced kern-GENERIC.tgz 
>on the memory card mentioned in attempt #1.  I then tried to repeat 
>attempt #1; but had the same results.
>Attempt #3
>I put the installation CDROM into my FreeBSD server and tried to install 
>via NFS using a pcmcia ethernet card (ne0).  I was able to connect via 
>NFS; but installation stalled for hours on kern-GENERIC.tgz.  There was 
>no progress bar; but the cursor moved to the next line a couple of 
>Attempt #4
>I cross compiled the build and release on the x86 box, configured 
>rc.conf and fstab and copied the build onto the 2GB microdrive.  The 
>kernel booted and init started.  Init tried to create 'mfs on dev', 
>which was followed by a continuous flurry of messages.  I was only able 
>to make out parts of messages:
>'command mknod on dev out of inodes' and
>'device out of space'
>After awhile, bootup continued; but the generation of keys for sshd 
>failed. I changed root's password, added a normal user in the wheel 
>group and rebooted -- which hung.  I'm not confident that the 
>installation is a good one.
>Any advice or help would be greatly appreciated.
>Andrew Gould
FWIW, here is an account of my experience with installing 1.6.2 on a MP 
780 (as related to someone else asking about it) - maybe I will go thru 
the exercise of re-installing 2.0 to see what happens - if  X windows 
pasting would work better now...  :

>> Deep:
>> Yes, I use a 512 MB CF card for my NetBSD installation, and it works
>> fine.  And, yes, this would be an excellent learning platform for unix,
>> since NetBSD is a direct derivative of the Berkeley version.  Although I
>> am more used to Solaris, which is mostly Sys V based, it is not hard to
>> pick up the diffs, mostly in a few key system directory layouts, not
>> much diff in usage, and the package systems are very similar (and a
>> wonderfully cohesive, consistent method to install software compared to
>> all the variants on the Linux distros, however, keep in mind that
>> sometimes you have to resort to installing non-updated packages from
>> older package dir versions such as 1.6 or 1.5).  I make ksh (Korn shell)
>> my default shell, and I'm happy.
>> The X windows is rather primitive, but functional up to the point of
>> copy/paste - I still have not got it down pat with the implementation on
>> a touch screen.  See the hpcmips mailing list archive on the NetBSD site
>> for the past month or 2 [8-9/2004] for more details.  At least I could jump around
>> several xterm windows to do different things in parallel.  It helped to
>> set their fonts a bit smaller, 6x10 I believe,  to get a usable number
>> of  lines viewable in each.  For some odd reason, the default xterm
>> specifies a 66-line window, and that's almost impossible to work with on
>> the 780 screen. Copy the .xinitrc file to your home dir, and modify that
>> to set the windows to about 15 lines for starters ("-geometry"
>> parameter), play with the fonts, and work from there.
>> I found 1.6.2, at least, supports my Prism2-based NetGear MA701 CF WiFi
>> card (in a PCMCIA adapter to go in that slot - install to your CF card
>> in the native CF slot, and do NOT put it in the other with a PCMCIA
>> adapter afterwards, since the slot has unique device designation, wd0,
>> that is key to filesystem definition).  The trick was in getting all the
>> settings figured out for the wiconfig command, but trial and error, and
>> rereading the docs helped me get through it.  If you go that route, I
>> can send my config for a guide.
>> However, I wound up using a generic NE-2000 clone wired card for an
>> FTP-based installation since I kept getting panics [the 'TLB out of
>universe' issue noted by Matt Dainty in response to Andrew Gould] during installation
>> when I tried to install from downloaded copies of the install file sets.
>>  I don't know if the combination of Windows 98 and Mozilla for
>> downloading/copying to CF of the files corrupted them or not. I remember
>> the downloads going extremely slowly - 3KBps-6KBps vs usual 100-200KBps
>> on my cable Internet connection - wondering if error correcting, which
>> did not fully work, was the issue.  This of course made the installer
>> think that would be my usual network connection, so I had to undo that,
>> and make the MA701 the default - a bit of work there, and not really
>> fully done, so I have to run a script after booting to start the card
>> with the correct settings, then the DHCP client - no biggie  ;-) .  Then
>> you have a fully network-enabled unix workstation at least from the
>> command line.
>> I would suggest that your first package to install after getting
>> networked would be elinks to give you at least a nicely enhanced
>> text-mode web (and directory/file) browser.  The available X windows
>> browsers are primitive - see the mailing list archive for some extended
>> discussion on that initiated by Tim Underwood (the guy is practically
>> conducting a tutorial-by-installment on getting hpcmips tailored for
>> usability on the mailing list - very informative Q&A resulting  ;-) .
>> What I did then, was to run the installer a first time from another
>> standard WinCE CF card in the PCMCIA slot with the basic install files
>> from
>>  When the installation system came up, I partitioned and formatted the
>> 512MB card in the native CF slot (wd0) so it had about 4-5MB for a
>> DOS/WinCE partition at the beginnning, and the  rest being allocated to
>> a BSD native partition (which is then carved up into "slices" for BSD
>> filesystems).  This allows placement of the pbsdboot.exe WinCE runtime
>> file and its config file on the DOS partition so you can boot into
>> NetBSD from WinCE (about the only way it can be done as far as I can
>> tell - pressing the power button while running NetBSD really just
>> suspends the 780 still under NetBSD control, so keep it plugged in!).
>> Keep in mind that pbsdboot.exe totally re-sets the 780, so any WinCE
>> configuring you do is completely gone, and if you re-set to bring that
>> back up, you even have to re-calibrate the touch screen, and re-set the
>> date/time.  I have found that running the bUSEFUL full backup to save
>> the WinCE system to a CF card dedicated to WinCE just before booting
>> NetBSD does the job of providing a source to restore everything as it
>> was (after calibrating and setting date/time of course  ;-) .
>> Remember to get subscribed to the mailing list since there are many more
>> knowledgeable folks there who can help with your questions.
>> Hope that helps, and have fun!
>> --
>> Rory ...