Subject: Re: Problem with a corrupted disklabel
To: Richard Danter <>
From: Richard Danter <>
List: port-hpcarm
Date: 05/16/2006 10:57:43
Richard Danter said the following:
> David Laight said the following:
>> On Thu, May 11, 2006 at 05:04:34PM +0100, Richard Danter wrote:
>>> Thanks Mark. For some reason my version of disklabel does not have the
>>> -D option. <sigh>
>> That only got added post 3.0
>> If you hexdump the start of the disk, the label is (probably) in sector
>> 0 (or maybe sector 1, or maybe the first (or second) sector of a netbsd
>> mbr partition).  In any case writing zeros to the sector with 'dd'
>> will zap it (but you might have to use disklabel -W to make the label
>> unprotected [1]).
>> 	David
>> [1] run 'sleep 9999 </dev/rwdxd' in another window (or with &) to keep the
>> diak open.
> Still no luck... I dd'd a load of zeros and then re-disklabeled it,
> format and installed. When I put the CF card in the Jornada though WinCE
>  says that the card needs to be formatted. Now I can't seem to get back
> to a state where I can even see the DOS partitions on both WinCE and NetBSD.

I fixed it! Woo hoo! The DOS partition table had also become corrupted
and I was able to fix that using fdisk. So between fdisk and disklabel I
can now get the kernel running.

There is a new problem, I will start a new thread for that though.

Thanks to all who helped with this one!