Subject: Re: Problem with a corrupted disklabel
To: David Laight <>
From: Richard Danter <>
List: port-hpcarm
Date: 05/12/2006 18:31:09
David Laight said the following:
> On Thu, May 11, 2006 at 05:04:34PM +0100, Richard Danter wrote:
>> Thanks Mark. For some reason my version of disklabel does not have the
>> -D option. <sigh>
> That only got added post 3.0
> If you hexdump the start of the disk, the label is (probably) in sector
> 0 (or maybe sector 1, or maybe the first (or second) sector of a netbsd
> mbr partition).  In any case writing zeros to the sector with 'dd'
> will zap it (but you might have to use disklabel -W to make the label
> unprotected [1]).
> 	David
> [1] run 'sleep 9999 </dev/rwdxd' in another window (or with &) to keep the
> diak open.

Still no luck... I dd'd a load of zeros and then re-disklabeled it,
format and installed. When I put the CF card in the Jornada though WinCE
 says that the card needs to be formatted. Now I can't seem to get back
to a state where I can even see the DOS partitions on both WinCE and NetBSD.

Feels like it is getting worse.

I tried letting WinCE format, then going back to NetBSD and
re-disklabeling and formatting again. When I put the card back in the
Jornada it does not complain about needing to be formatted, but it also
does not see the files I copied to the DOS partition.

Any other ideas?

Many thanks