Subject: two X troubles
To: None <>
From: Michael W . Lucas <>
List: port-hpcarm
Date: 04/16/2003 14:24:41

I am having two problems with my new Jornada, which neither the man
pages nor Google seems to know anything about.

1) My goal is to run X as a regular user.  When I run startx as a
regular user, I get errors:

/dev/wsmouse0: Permission denied
/dev/wsmouse1: Permission denied
/dev/wsmouse2: Permission denied
use RAW XT keyboard, /dev/ttyE0

Fatal server error:
Can't open pointer device

X runs when I am root, however.

My first thought is that I needed more generous permissions on
/dev/wsmouse.  I could give everyone read permissions, but write
permissions simply don't take on these devices.  This was rather 

I tried using xdm at boot, from rc.conf, but the console simply locked
up.  I thought that xdm might be on another virtual console, but it
appears that the ctrl-alt-pseudofunctionkey part of wscons doesn't
work with hpcarm.

Any suggestions on how to best run X as a regular user?

2) keyboard and X

When I get X/twm up and running as root, and get an xterm firing, I
can't actually type anything.  Most keys have no effect, but a few
make the occasional backslash or other symbol appear.  I've found
several keycap files in the archives, and tried them by putting

xmodmap /home/mwlucas/keymap

in my .xinitrc, with no success.

Anyone have any suggestions on what to try next, or what could be wrong?

Thanks for any hints,


Michael Lucas,

           Absolute BSD: