Subject: Re: More on the Jornada X touch screen problem
To: None <>
From: Brad Spencer <>
List: port-hpcarm
Date: 08/27/2002 20:08:01
   At 10:32 p.m. 26/08/2002 +0200, you wrote:
   >FWIW, I just upgraded my kernel to -current and tried the new X11 tar
   >ball. The keyboard now works, but the touch panel does not work anymore.

   I have that problem,  with the MERIDOC kernel using auto build binaries 
   from 19-Aug, so it may not be the kernel but something else.

For reference, my Jornada has product ID F1816A ABA and A00-0605JP on the
back.  By all accounts it is a U.S. version of the product.  It claims to
run Pocket-PC 2000.

When I boot up, I select the Japanese version of the 720 from the menu.

A dmesg looks like this:

NetBSD 1.6E (MERIADOC) #8: Tue Aug 27 18:42:55 EDT 2002
total memory = 32768 KB
avail memory = 26420 KB
using 435 buffers containing 1740 KB of memory
mainbus0 (root)
cpu0 at mainbus0: SA-1110 step B-4 (SA-1 core)
cpu0: DC disabled IC disabled WB disabled EABT
cpu0: 16KB/32B 32-way Instruction cache
cpu0: 8KB/32B 32-way write-back Data cache
saip0 at mainbus0
saost0 at saip0 addr 0x90000000-0x9000001f
saost0: SA-11x0 OS Timer
sacom0 at saip0 addr 0xd000d000-0xd000d023 intr 17
sacom0: unknown SA11x0 UART
sacc0 at saip0 addr 0x40000000-0x40001fff
sacc0: SA1111 rev 2.1
sacpcic0 at sacc0
pcmcia0 at sacpcic0
pcmcia1 at sacpcic0
sed0 at saip0
sed0: Epson SED1356, console
sed0: framebuffer address: 0x48200000
hpcfb0 at sed0: 640x240 pixels, 65536 colors, 80x24 chars
wsdisplay0 at hpcfb0 kbdmux 1: console (std, vt100 emulation)
wsmux1: connecting to wsdisplay0
hpcfb: 640x240 pixels, 65536 colors, 80x24 chars
wsdisplay0: screen 1 added (std, vt100 emulation)
j720ssp0 at saip0 addr 0x80070000-0x800700ff
wskbd0 at j720ssp0: console keyboard, using wsdisplay0
wsmouse0 at j720ssp0 mux 1
ipl_bio=00020203 ipl_net=00020002 ipl_tty=00020002 ipl_imp=00020002
ipl_audio=00020002 ipl_imp=00020002 ipl_high=00020002 ipl_serial=00020002
clock: hz=100 stathz = 64
IPsec: Initialized Security Association Processing.
sacpcic0: card present
wdc0 at pcmcia1 function 0
wd0 at wdc0 channel 0 drive 0: <SanDisk SDCFB-512>
wd0: drive supports 1-sector PIO transfers, LBA addressing
wd0: 488 MB, 993 cyl, 16 head, 63 sec, 512 bytes/sect x 1000944 sectors
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
hpcfb: 640x240 pixels, 65536 colors, 80x24 chars
wsdisplay0: screen 2 added (std, vt100 emulation)
hpcfb: 640x240 pixels, 65536 colors, 80x24 chars
wsdisplay0: screen 3 added (std, vt100 emulation)
hpcfb: 640x240 pixels, 65536 colors, 80x24 chars
wsdisplay0: screen 4 added (std, vt100 emulation)

X, the keyboard and the touch screen all work fine.

   What date of current works with the touch panel ?

The MERIADOC kernel is a 1.6E system from early August.  Sorry, I don't
remember the exact date.

   cu -1200 -l/dev/wsmouse0
   shows output for screen touchs while X is running.
   Doesn't X open the mouse exclusively?

As far as I can tell, it doesn't.  Although, I have noticed you sometimes
have to be careful, otherwise you can't CTRL-C out.

   cu -1200 -/dev/wsmouse1 reports not configured.

   pstat -t doesn't show wsmouse open when X is running  (I assume if I can cu 
   to it, it is a tty)

It doesn't here, either.

68 terminal devices
mem      0   0   0    0   0       0 -             0     0 termios
ttyE0    0   0   0 1248 256       0 OC     C0C8EB40   309 termios
ttyE1    0   0   0 1248 256       7 OC     C0C8EB80   202 termios

. bunch of ttypN lines...

ttyE2    0   0   0 1248 256       7 OC     C0D22940   203 termios
mem      0   0   0    0   0       0 -             0     0 termios
mem      0   0   0    0   0       0 -             0     0 termios

I don't think that it works like a true tty.

What does the X server say when it starts.  I get a single line that
indicates that it is using ttyE0 and the resolution.  When the X server
wanted to use the IBM keyboard codes, it would also indicate that.  As
far as I can tell, when it uses wskbd it will only print the single line.

     I have tried it with and without wscons=YES in rc.conf

   my wscons.conf is the default provided in the distribution.

What is in your /etc/ttys file??

Please note that in order to use the keyboard on the X server I put up you
will need the .Xmodmap I created.  I put up a copy of that at:


   ---------------------------  Yang Mudah dan Menghibur ---------------------------------
    Hosting menjadi mudah dan murah hanya di PlasaCom. Klik
    F1 Mania!! Ikuti F1 Game di Obelix Game Corner di

Brad Spencer -  - & - [IPv6 only]
[finger for PGP public key]