Subject: strange inability to boot diskless
To: None <>
From: Paul <>
List: port-hp300
Date: 08/27/1999 21:34:24
Dear Helpful People;

	I upgraded to netbsd1.4 from 1.1 not too long ago. I have 2 340's, one
of which is hooked up to a scsi disk, and the other, which I have been
netbooting off and on for years.
	I recently tried to netboot it though after upgrading, and failed.
	Everything seems to work beautifully; rbootd sends over SYS_UBOOT,
that asks rarpd who it is, and then it gets all the correct information
about its server/root from bootparamd. Then it sucks over the kernel via nfs.
As soon as the kernel is loaded, however, the machine just hangs. Ive
built my own kernel from DISKLESS, and tried the diskless kernel from
the ftp site, and they both hang. tcpdump reveals absolutely no network
traffic from the diskless client after it appears to hang.

	If I try and boot using the GENERIC kernel, it runs further after loading,
then prompts for a root, dump, and filesystem (I give it le0, none, and
nfs) Then it uses rarp to find out who it is, then claims its using 
bootparam, but sends these packets until it times out:

# squidclock is the diskless client

tcpdump host squidclock 
21:28:41.973068 rarp reply at
21:28:42.037308 arp who-has tell
21:28:42.042320 > udp 96
21:28:43.035204 > udp 96
21:28:45.035160 > udp 96

What is it doing?

[] /home/export/squidclock/root (Root): rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100005    1   udp    930  mountd
    100005    3   udp    930  mountd
    100005    1   tcp   1018  mountd
    100005    3   tcp   1018  mountd
    100026    1   udp    917  bootparam

Im stumped. Can anyone suggest anything? 

Thankful for any help;