Subject: post-install problems
To: None <>
From: dustin sallings <>
List: port-hp300
Date: 09/13/1998 13:12:11
	Hey, I got NetBSD 1.3.2 running on my 340 last night, but I've got
a problem that can take two possible solutions (fixing it, and working
around it).

	The problem is that, though I offset partition a by one, it won't
let me disklabel the disk to boot, complaining that a and c overlap:

fuct# ./installboot inst.lif /dev/rsd0c 
disklabel: boot overlaps used partition a
disklabel: cannot install boot program

	(if that syntax is incorrect, it also did it when it was trying to

	The two acceptable workarounds here are:

	a) getting that to work
	b) getting the SYS_UBOOT I get from rbootd to boot sd2a:netbsd

	OBTW, if you didn't notice, this is a SCSI disk, and I have no
HP-IB disks.  The install works fine (though it reminded me of the 1.0
install for PC), it's just a hassle to boot.

	I noticed that in this install, it does mount the critical
filesystems *before* the network configuration, which was a complaint I
had about the i386 port.  In fact, I diff'd my modified rc and netstart I
got from my laptop, and there were no differences from the hp300 port, so
it worked much nicer out of the box.  However, there is still no
/etc/dhclient.conf.  I was able to bring it up with the following config:

----------- begin /etc/dhclient.conf --------------
script "/etc/dhclient-script";
----------- end   /etc/dhclient.conf --------------

	Is there a reason there's no default config?  (I know, this is
more a general question, but it was closer to working on this port than

SA,         My girlfriend asked me which one I like better.
pub  1024/3CAE01D5 1994/11/03 Dustin Sallings <>
|    Key fingerprint =  87 02 57 08 02 D0 DA D6  C8 0F 3E 65 51 98 D8 BE 
L_______________________ I hope the answer won't upset her. ____________