Subject: Re: AW: Problems with Qunatum LPS240S and Apollo 425t
To: None <port-hp300@NetBSD.ORG>
From: Ian Clark <>
List: port-hp300
Date: 03/12/1998 21:10:14
On Wed, 11 Mar 1998, =?iso-8859-1?Q?Torsten_Schl=FCter?= wrote:

> Hi,
> i tried to change the disklabel (like you and the Quantum HomePage suggest) but after a
> 'disklabel -e -r sd1' 
> and editing the label i get the following error Message:
> 	8 partitions:
> 	#        size   offset    fstype   [fsize bsize   cpg]
> 	  a:   479066      266      4.2BSD     1024  8192    16   # (Cyl.    3*- 1800*)
> 	  c:   479332        0        boot                        # (Cyl.    0 - 1802*)
> 	/tmp/EdDk.a07592a: 23 lines, 537 characters
> 	disklabel: ioctl DIOCWDINFO: Open partition would move or shrink
> 	re-edit the label? [y]: 
> How can I manage that to put the new label on the disk?
> BTW The disk is not mounted! The same result is achieved if i use the -R option with the label wirtten in a file or the -r option to use the device directly.
> ... more stuff deleted....

I was going to ask the same question myself. I have got around this 
several times by Netbooting SYS_INST and using the 'Disklabel' option 
from that to set up an initial disklabel.

V TWINS: the only practical alternitive to the single :- Phil Irving

21 Year old Moto Morini, 16 year old Moto Guzzi, 23 year old car -
So what's the fuss about a couple of 10 year old workstations?
Ian Clark VK3KRI