Subject: Re: Binary snapshot available
To: None <thorpej@NetBSD.ORG>
From: Elmar Kolkman <>
List: port-hp300
Date: 03/18/1997 08:43:17
> Hi Folks...
> I've just put up a binary snapshot of March 13 vintage sources, with
> a few changes to support the m68k8k executable format.  I have since
> committed those changes, which will appear in the next SUP scan.
> (I committed them after uploading the snapshot to the FTP server, to
> make the transition easier.)


> This is a binary snapshot of NetBSD/hp300 1.2C, build from NetBSD-current
> sources from March 13, 1997 with a few minor changes designed to ease
> the transition from m68k4k a.out to m68k8k a.out executable formats.
> Since these executables are m68k8k format, you _must_ install one of
> the provided snapshot kernels before installing any of these executables.
> If you do not, you will no longer be able to use your system!  Once
> you install the new executables, you will _not_ be able to boot a
> running system with old kernels!
> Note that, due to a bug in the older boot blocks, you _must_ install a
> new boot block before booting a new kernel!  New boot blocks will be
> able to boot old- or new-format kernels.  Once you install the boot
> block, make sure it is revision 1.7 (printed in the banner when the
> boot program starts).

Hm. Does this account for diskless booting too ?
Because, there is no new SYS_NBOOT.

> The recommended upgrade procedure is:
> 	(1) Install new boot block:
> 		cp uboot.lif /usr/mdec
> 		cd /usr/mdec
> 		./installboot uboot.lif /dev/rXXNc
> 	    ...where XXN is the name of your root disk, e.g. sd0, rd0, etc.

Would love too, but... you need a running system for this kind of things, and
mine isn't running NetBSD as of yet... And a new SYS_NBOOT isn't distributed
> 	(2) Backup your old kernel:
> 		cp /netbsd /netbsd.old

Ok. This worked... ;-)
> 	(3) Install and boot new kernel:
> 		cp netbsd-gen /netbsd
> 		reboot

I used both, with the same result (netbsd-gen AND netbsd-dl) : After the HP
got the kernel, it didn't do anything... I had a tcpdump running on the
networkserver it booted from, but no more packets where showed (I didn't have
to define a filter, the net is just for those two machines for now).

I'm at a loss here.
I see two possible problems:
	1) wrong bootblock. With a new miniroot and a unliffed uboot I could
		try booting from tape again, or with a new SYS_NBOOT.
	2) the new kernel doesn't support the DCM card as console device.

If someone is interested, I tried with the previous snapshot (with the
february sources) and that kernel at least started, showed the containment of
the HP but crashed in the dcmxint routine with a memory fault (another point
as the previous crashes I got with the january snapshot). I got a terminal
capture, but would like to first try with the newest snapshot.

Thanks in advance,


Terror : Appropriate reaction after considering the terrain
				Henry Beard & Roy McKie, A skiers dictionary