Subject: Interesting(?) NetBSD (HP-340) booting problem...
To: None <port-hp300@NetBSD.ORG>
From: Greg Oster <>
List: port-hp300
Date: 07/12/1995 16:38:49

After successfully installing NetBSD-1.0 on an HP-300 (it had an uptime
of 40 days at one point :-) ), I/we want to get NetBSD running on a group of
HP-340's.  (These machines are to be used as the "playground" machines
for an Operating Systems class).  

However, we've run into a small(?) snag:
After writing the root image to the (SCSI) drive, and trying to boot with it, 
we get the error message:  "Read Error :CDC 94161-9, 1400, 0".
This message is printed <after> the "BOOTING SYSTEM" message, but 
<before> the netbsd boot prompt (i.e. where you can select single/multi-user,
etc) comes up.  "CDC 94161-9" is the "name" of the drive.  It doesn't seem to
matter if the SCSI ID is 0 or something else - same problem.

We tried this on 3 different HP-340s.  All have the same SCSI card 
(On booting, it reports a "HP98265 (SCSI S 16) at 14" scsi card, although
"HP98658A at 14" is stamped on the physical card.).  
The disk boots just fine on the HP-300.  We also used the 340 to write the 
root image out to the drive (the initial disk we tried with had the root
image installed by the HP-300) -- that didn't help either (not that we expected
it to, but you never know..) 
The BOOTROM on the 340's are: Copyright 1988, Rev. C 1

I've got no idea what the problem might be.  What really gets me is that
the disk boots fine on the HP-300, but not the 340's :-( 

Do I need to find a newer/older set of bootblocks?  Can I roll them myself
from the 1.0 source, or are they already available via ftp?

Any info would be most appreciated....



Greg Oster
Department of Computational Science
University of Saskatchewan, Saskatoon, Saskatchewan, CANADA