Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Panics going multiuser with NetBSD 8, 9, current


I have an Amiga 4000 with a CyberStorm Mk3 on which I ran NetBSD for years. It became flakey, so it was put away until I had the time and parts to recap it and fix it. I've finally done that! Booted it up in to NetBSD 6 and ran it for several days as a test. I ran a new pkgsrc bootstrap, compiled a handful of packages, and saw absolutely no problems with the hardware.

Then it came time to try a modern NetBSD. I tried GENERIC from NetBSD 9.2, and I got panics on every boot. I also tried 9.0, which runs fine on my Blizzard 1260 A1200, 8.2 and current, but they panic similarly. Revisiting NetBSD 6 had no issues.

panic: MMU fault
cpu0: Begin traceback...
db_panic(8,465000,0,259170,95cbb74) at 0
vpanic(32aefa,95cbb80,95cbb80,39f80,32aefa) + 162



The first is blurry because it was taken from a video because it was scrolling too fast to capture any other way.

I noted that I can boot the NetBSD 9.2 install kernel, or a current GENERIC kernel, can boot just fine with a miniroot filesystem, and I can fsck, disklabel, ftp, tar & gunzip, et cetera.

The moment I try to chroot to a filesystem, either on an IDE wd disk or on
a SCSI disk on the CyberStorm Mk3 SCSI bus, it panics. Here's the latest, booted from a GENERIC current kernel using the 9.2 miniroot, where it paniced the moment I tried to chroot to a newly newfs'd FFSv2 filesystem:


Any ideas or suggestions about what to try next?


Home | Main Index | Thread Index | Old Index