Subject: Re: Driver for D-Link DFE 500TX rev C-2
To: None <>
From: Steve Kirk <>
List: port-alpha
Date: 01/26/2006 14:46:12
On Thu, Jan 26, 2006 at 09:24:40AM +0100, Jochen Kunz wrote:
> On Wed, 25 Jan 2006 18:26:03 +0000
> Steve Kirk <> wrote:
> > I'm having a problem with a D-Link DFE500TX rev C-2 card
> [...]
> > However it appears that it isn't recognised under NetBSD/alpha?
> What does the kernel report? Is the card detected at all? Even if there
> is no driver the kernel will print somthing like "foo at bar not
> configured". Is the card listed when you run "pcictl /dev/pci0 list"?
> (You may have to iterate through all /dev/pci* devices.)
> -- 


I should have put more information in my original email about this

The kernel didn't detect the card at all initally, and pcictl was
showing the card as "Anigma" which seemed odd.

I had tried 2 accton EN1207D cards in the machine, but with either or
both of these cards in the machine, it would error as SRM tried to
configure them during the config adapters stage. This would send the
console into an endless loop.

I've since removed these cards, and also an Adaptec 2940U/UW SCSI
card that was unused. I then put the D-Link card back in late last night
and started up the machine...and it 'Just Worked'! It was recognised as
tulip0 by the SRM consolse and the tlp driver worked.

I really have no idea why, I can't see why removing the Adaptec card
would make a difference...