Subject: Re: bootable RAID-1 array problems
To: Ray Phillips <>
From: Greg Oster <>
List: port-alpha
Date: 08/27/2004 12:29:58
Ray Phillips writes:
> I tried again to make a RAID-1 bootable array using the IDE pair of 
> disks I mentioned, this time in a PC.  I sat in front of the console 
> when I issued the `raidctl -F component0 raid0' command and observed 
> the failure occur.  It certainly happened in the vicinity of the bad 
> sectors, so they must have been the cause.  So, it seems a sector by 
> sector copy is done of the whole RAID partition during the 
> reconstruction process, regardless of what kinds of partitions are 
> within it?


> There was something strange about the SCSI pair too but I can't 
> explain it.  I swapped the SCSI ID's of the two disks and plugged 
> each into the other's connector, tried the process again, and it 
> worked beautifully.  Hot-removing one, formatting it under DOS, 
> plugging it back into the Alpha, and adding it back into the array 
> went smoothly too, just as you'd hope it would.
> >Was the parity of the sets "clean" when you started the reconstruct? )
> No, the parity was dirty, and I couldn't see how to make it clean 
> before adding the second RAID partition to the array.  Is it possible 
> to do that?

'raidctl -i' will iniitalize the parity... I don't recall off-hand 
whether it works if a component is missing though... (it's the same 
difference either way if a component is missing... it can only work 
with what bits are left, regardless of whether or not the parity was 
clean at the time the component disappeared...)


Greg Oster