Subject: SMBFS on alpha?
To: None <>
From: Paul Mather <>
List: port-alpha
Date: 05/30/2003 12:28:49
I notice there is a mount_smbfs.  As I use this under FreeBSD/i386
occasionally, I thought I'd give it a whirl on my NetBSD/alpha box at

I built a kernel with "file-system SMBFS" and "pseudo-device nsmb"
options and rebooted using this kernel.  But, when I issued a
mount_smbfs, I got the following error:

     mount_smbfs: can't get handle to requester (no /dev/nsmb* device)

So, I went to run /dev/MAKEDEV to make /dev/nsmb0 only to find it
doesn't include that device.  Is this a subtle way of saying the SMBFS
file system and mount_smbfs aren't working on alpha? :-)  I looked, and
the NetBSD/i386 MAKEDEV includes nsmb*, so I guess it is available
under NetBSD/i386.  (I tried mknod using the same major and minor
numbers, but still get the same error from mount_smbfs.)

I am curious to know why config didn't complain that there was no nsmb
entry in /sys/arch/alpha/conf/majors.alpha and successfully built the
kernel anyway.  (Did it assume nsmb was a network device---a la ppp,
gif, faith, etc.---and hence didn't require one?)  Similarly, why have
a /usr/lkm/smbfs.o if it won't work?  Is it just to tantalise? :-)

Is anyone able to confirm mount_smbfs working for them under
NetBSD/alpha?  BTW, my system is 1.6T-CURRENT.




"Without music to decorate it, time is just a bunch of boring production
 deadlines or dates by which bills must be paid."
        --- Frank Vincent Zappa