Subject: Re: Stupid XalphaNetBSD perms question
To: None <>
From: None <>
List: port-alpha
Date: 08/23/2002 08:39:48
On Thu, Aug 22, 2002 at 10:52:31AM +0300, wrote:
> On Thu, Aug 22, 2002 at 03:37:32AM -0400, Roland Dowdeswell wrote:
> > 
> > but it runs properly as root?  (c.f. my prior email asking if this was
> > still working for people.)
> It works for root and for non-root with liberal /dev/ws* permissions.
> I've yet to try TGA2, I'll try it probably tonight.

Tried it (3d30, 1280x1024 8bit, bt485) and it worked with the same
problems I've had previously ie. the colormap was screwed up. I tried the
cmap.c you posted a few months ago but I couldn't get it to actually 
change the colormaps, cmap 0 255:255:255, cmap 1 255:255:255 and all
other variations didn't affect the colormaps at all (with/without X).

I also found out that 3d30 doesn't want to do sync-on-green, probably
due to the VGA-stuff and the lack of SRM-initialization. I've tried
these cards so far with a 500/500, AS 255, AS 600 and AS 1000 with 
the same problems. I've got the check the firmware versions next, if
they have anything to do with this.