Subject: Re: TC ethernet issue
To: Lord Isildur <>
From: Clemmitt Sigler <>
List: port-alpha
Date: 04/19/2002 12:19:24

On Fri, 19 Apr 2002, Lord Isildur wrote:
> same situation here, the pmad's pass all the tests, they look fine from 
> the chevron. a couple of them that i'd tried it with worked fine in 
> ultrix, on a decstation, too.. 

I can confirm that the TC PMAD-AA's work fine in DEC 3000/300's under
Tru64 Unix, but don't work under any NetBSD that's been tried.  They
all give the "reg did not settle" error on initialization.

> well, if this really doesnt work ill see if i can get some time to look 
> into fixing it :-) (i'd really like to use this 3k300 as a firewall)

Me, too :^)  I'm willing to help if I can, but I don't have the experience
to do the job myself -- not much of a kernel/driver hacker.  Here's the
best I can do at an analysis of the problem for now -->

I think the problem originates from le_tc_attach (in
syssrc/sys/dev/tc/if_le_tc.c) which calls dec_le_common_attach (in
syssrc/sys/dev/dec/if_le_dec.c).  This then calls le_dec_wrcsr which then
calls le_dec_writereg (LEWREG), where the "reg did not settle" error

Note that in syssrc/sys/dev/tc/if_le_ioasic.c, dec_le_common_attach is
called from le_ioasic_attach and this works correctly.  OTOH,
in syssrc/sys/dev/tc/if_le_tc.c, dec_le_common_attach is called from
le_tc_attach and this doesn't work.  It seems to me the "breakage"
must come from the differences in if_le_tc.c and if_le_ioasic.c.
Does that sound reasonable?

					Clemmitt Sigler